forked from Sysdeploy/openwrt
Copy additional bootconfig as current.txt
This commit is contained in:
parent
0a0851250a
commit
644618d9c4
|
@ -110,7 +110,7 @@ chmod 0400 files/etc/dropbear/authorized_keys
|
||||||
mkdir -p files/etc/uci-defaults
|
mkdir -p files/etc/uci-defaults
|
||||||
cp ${pwd}/defaults/* files/etc/uci-defaults
|
cp ${pwd}/defaults/* files/etc/uci-defaults
|
||||||
|
|
||||||
cp ${pwd}/overlays/dualeth.txt ${BOOTSOURCE}
|
cp ${pwd}/overlays/dualeth.txt ${BOOTSOURCE}/current.txt
|
||||||
|
|
||||||
cp ${BOOTCONFIG} .
|
cp ${BOOTCONFIG} .
|
||||||
|
|
||||||
|
@ -120,19 +120,23 @@ dtparam=spi=on
|
||||||
dtparam=i2s=on
|
dtparam=i2s=on
|
||||||
dtoverlay=i2c-rtc,ds1307
|
dtoverlay=i2c-rtc,ds1307
|
||||||
|
|
||||||
include dualeth.txt
|
include current.txt
|
||||||
EOF
|
EOF
|
||||||
|
|
||||||
|
pushd ${BOOTSOURCE}
|
||||||
|
git apply ${pwd}/patches/bootconfig-add.patch
|
||||||
|
popd
|
||||||
|
|
||||||
make image PROFILE=${PROFILE} \
|
make image PROFILE=${PROFILE} \
|
||||||
PACKAGES="${PACKAGES}" DISABLED_SERVICES="dropbear" FILES="files"
|
PACKAGES="${PACKAGES}" DISABLED_SERVICES="dropbear" FILES="files"
|
||||||
|
|
||||||
mv ${IMAGE_PATH}-squashfs-factory.img.gz ${IMAGE_PATH}-squashfs-factory-dualeth.img.gz
|
mv ${IMAGE_PATH}-squashfs-factory.img.gz ${IMAGE_PATH}-squashfs-factory-dualeth.img.gz
|
||||||
mv ${IMAGE_PATH}-squashfs-sysupgrade.img.gz ${IMAGE_PATH}-squashfs-sysupgrade-dualeth.img.gz
|
mv ${IMAGE_PATH}-squashfs-sysupgrade.img.gz ${IMAGE_PATH}-squashfs-sysupgrade-dualeth.img.gz
|
||||||
|
|
||||||
cp ${pwd}/overlays/sensing.txt ${BOOTSOURCE}
|
cp ${pwd}/overlays/sensing.txt ${BOOTSOURCE}/current.txt
|
||||||
cp ${pwd}/overlays/*.dtbo ${OVERLAYSOURCE}
|
cp ${pwd}/overlays/*.dtbo ${OVERLAYSOURCE}
|
||||||
cp config.txt ${BOOTCONFIG}
|
cp config.txt ${BOOTCONFIG}
|
||||||
echo "include sensing.txt" >> ${BOOTCONFIG}
|
echo "include current.txt" >> ${BOOTCONFIG}
|
||||||
pushd ${KERNELSOURCE}
|
pushd ${KERNELSOURCE}
|
||||||
git apply ${pwd}/patches/overlay-add.patch
|
git apply ${pwd}/patches/overlay-add.patch
|
||||||
popd
|
popd
|
||||||
|
|
10
patches/bootconfig-add.patch
Normal file
10
patches/bootconfig-add.patch
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- a/Makefile 2023-05-17 03:13:19.345089802 +0300
|
||||||
|
+++ b/Makefile 2023-05-17 03:15:55.564872084 +0300
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
mcopy -i $@.boot cmdline.txt ::
|
||||||
|
mcopy -i $@.boot config.txt ::
|
||||||
|
mcopy -i $@.boot distroconfig.txt ::
|
||||||
|
+ mcopy -i $@.boot current.txt ::
|
||||||
|
mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
|
||||||
|
$(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
|
||||||
|
mmd -i $@.boot ::/overlays
|
Loading…
Reference in New Issue
Block a user