Remove reverting of the i2c-tools package - fixed upstream
buildbot/multibuild_parent Build done. Details
buildbot/travis_bionic Build done. Details
buildbot/job/openwrt Build done. Details

This commit is contained in:
Lee Miller 2023-11-22 01:28:47 +02:00
parent 2b5cbe32df
commit 42ca3e439b
Signed by: lee.miller
GPG Key ID: 4F97A5EA88F4AB63
2 changed files with 0 additions and 36 deletions

View File

@ -26,8 +26,6 @@ sed -i "s/\(packages.git\)\^.*/\1;openwrt-22.03/g" feeds.conf
./scripts/feeds update -a
./scripts/feeds install -a
git apply ${pwd}/patches/i2c-tools-revert.patch
make defconfig
# Enable collectd network encryption
echo "CONFIG_PACKAGE_COLLECTD_ENCRYPTED_NETWORK=y" >> .config

View File

@ -1,34 +0,0 @@
--- a/feeds/packages/utils/i2c-tools/Makefile 2023-10-19 02:48:26.528051917 +0000
+++ b/feeds/packages/utils/i2c-tools/Makefile 2023-10-19 02:50:13.281230932 +0000
@@ -9,7 +9,7 @@
PKG_NAME:=i2c-tools
PKG_VERSION:=4.3
-PKG_RELEASE:=3
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/utils/i2c-tools
@@ -67,9 +67,8 @@
This package contain the Python3 bindings for Linux SMBus access through i2c-dev.
endef
-PYTHON3_PKG_BUILD_PATH:=py-smbus
-PYTHON3_PKG_WHEEL_NAME:=smbus
-PYTHON3_PKG_WHEEL_VERSION:=1.1
+PYTHON3_PKG_SETUP_ARGS:=
+PYTHON3_PKG_SETUP_DIR:=py-smbus
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
@@ -87,10 +86,6 @@
$(CP) $(PKG_BUILD_DIR)/lib/libi2c.{a,so*} $(1)/usr/lib/
endef
-define Build/Install
- $(call Py3Build/Install)
-endef
-
define Package/libi2c/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/libi2c.so* $(1)/usr/lib/