Add waveshare dtbo and bootconfig for 2.8inch RPi LCD (A)

This commit is contained in:
Lee Miller 2023-07-04 16:46:45 +03:00
parent 9bad036498
commit e7e277b444
Signed by: lee.miller
GPG Key ID: 4F97A5EA88F4AB63
4 changed files with 39 additions and 1 deletions

View File

@ -146,8 +146,13 @@ make image PROFILE=${PROFILE} EXTRA_IMAGE_NAME="dualeth" \
PACKAGES="${PACKAGES}" DISABLED_SERVICES="dropbear" FILES="files" || exit 1
sed -i "s|,i2c_csi_dsi||g" ${BOOTSOURCE}/current.txt
sed -i "s/CONFIG_TARGET_ROOTFS_PARTSIZE=.*/CONFIG_TARGET_ROOTFS_PARTSIZE=768/g" .config
cp ${pwd}/overlays/waveshare32b.dtbo ${OVERLAYSOURCE}
cp ${pwd}/overlays/waveshare.txt ${BOOTSOURCE}/current.txt
cp ${OVERLAYSOURCE}/Makefile ${OVERLAYSOURCE}/Makefile.orig
pushd ${KERNELSOURCE}
git apply ${pwd}/patches/overlay-add-waveshare.patch
popd
make image PROFILE=${PROFILE} EXTRA_IMAGE_NAME="waveshare" \
PACKAGES=" \
@ -160,8 +165,10 @@ make image PROFILE=${PROFILE} EXTRA_IMAGE_NAME="waveshare" \
cp ${pwd}/overlays/sensing.txt ${BOOTSOURCE}/current.txt
cp ${pwd}/overlays/*.dtbo ${OVERLAYSOURCE}
rm ${OVERLAYSOURCE}/waveshare32b.dtbo
cp config.txt ${BOOTCONFIG}
echo "include current.txt" >> ${BOOTCONFIG}
cp ${OVERLAYSOURCE}/Makefile.orig ${OVERLAYSOURCE}/Makefile
pushd ${KERNELSOURCE}
git apply ${pwd}/patches/overlay-add.patch
popd

21
overlays/waveshare.txt Normal file
View File

@ -0,0 +1,21 @@
dtparam=i2c_vc=on
dtoverlay=i2c-rtc,pcf85063a
# Waveshare config-32 for 2.8inch RPi LCD (A)
enable_uart=1
# Enable audio (loads snd_bcm2835)
dtparam=audio=on
dtoverlay=waveshare32b:rotate=270
# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt 480 320 60 6 0 0 0
hdmi_drive=2
[all]
[cm4]
otg_mode=1

BIN
overlays/waveshare32b.dtbo Normal file

Binary file not shown.

View File

@ -0,0 +1,10 @@
--- a/arch/arm64/boot/dts/overlays/Makefile 2023-07-04 16:38:37.955239160 +0300
+++ b/arch/arm64/boot/dts/overlays/Makefile 2023-07-04 16:40:54.058192471 +0300
@@ -3,6 +3,7 @@
dtb-$(CONFIG_ARCH_BCM2835) += overlay_map.dtb
dtbo-$(CONFIG_ARCH_BCM2835) += \
+ waveshare32b.dtbo \
act-led.dtbo \
adafruit18.dtbo \
adau1977-adc.dtbo \