Add kmod-rtc-pcf85063

This commit is contained in:
Lee Miller 2023-03-19 04:25:35 +02:00
parent 237ddbf469
commit ec0c67a138
Signed by: lee.miller
GPG Key ID: 4F97A5EA88F4AB63
2 changed files with 32 additions and 3 deletions

View File

@ -24,9 +24,8 @@ cat ${pwd}/feeds.conf >> feeds.conf
./scripts/feeds update -a
./scripts/feeds install -a
make defconfig
git apply ${pwd}/patches/i2c-mux-pinctrl.patch
git apply ${pwd}/patches/rtc-pcf85063.patch
# Add kmods
cat << "EOF" >> Config-build.in
@ -35,8 +34,13 @@ config PACKAGE_kmod-i2c-mux-pinctrl
tristate
default m
config PACKAGE_kmod-rtc-pcf85063
tristate
default m
EOF
make defconfig
# Enable collectd network encryption
echo "CONFIG_PACKAGE_COLLECTD_ENCRYPTED_NETWORK=y" >> .config
@ -69,7 +73,7 @@ echo "CONFIG_TARGET_ROOTFS_EXT4FS=n" >> .config
PACKAGES="kmod-i2c-bcm2835 kmod-i2c-mux kmod-i2c-mux-pinctrl \
kmod-nf-nathelper-extra \
kmod-rtc-ds1307 kmod-rtc-pcf8563 \
kmod-rtc-ds1307 kmod-rtc-pcf8563 kmod-rtc-pcf85063 \
kmod-usb-audio kmod-usb-net-rtl8152 \
alsa-lib pciutils usbutils \
kmod-usb-net-qmi-wwan libqmi qmi-utils uqmi luci-proto-qmi \

View File

@ -0,0 +1,25 @@
--- a/package/kernel/linux/modules/other.mk 2022-10-14 22:44:41.000000000 +0000
+++ b/package/kernel/linux/modules/other.mk 2023-03-19 01:56:30.670490547 +0000
@@ -612,6 +612,22 @@
$(eval $(call KernelPackage,rtc-pcf8563))
+define KernelPackage/rtc-pcf85063
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Philips PCF85063 RTC support
+ DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+ DEPENDS:=+kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_PCF85063 \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf85063.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-pcf85063)
+endef
+
+define KernelPackage/rtc-pcf8563/description
+ Kernel module for Philips PCF85063 RTC chip.
+endef
+
+$(eval $(call KernelPackage,rtc-pcf85063))
define KernelPackage/rtc-pcf2123
SUBMENU:=$(OTHER_MENU)